Need help with simple truss roof


Recommended Posts

Hi everyone,


Could I get someone to look at the attached file in order to help me understand how to get a truss roof on the simple building that is shown 200' or so to the right of the house in the file. I am a beginner user and have read many of the user resources for pole barns etc from chief architect.


However, I am having an impossible time putting trusses for the roof on the small building. It keeps saying "can't find roof plane" or something of that nature.


Could someone take a look at the building I am speaking of and help me understand what I am not doing.


Thank you all so much for your help and sorry for asking what I believe is a simple question, but I just can't get the roof trusses to generate.


Link to comment
Share on other sites

So I have started to look into my problem above even more and when I create a gable building in a new file and try to apply a roof truss to the structure, everything works the way it should.


So next I copied this structure (made in a completely new file) into the file (DadHouse) that I previously attached and it stripped the ability to add the truss to the structure...


I don't know what's going on... Does anyone have any ideas for me.


Thank you all again!!

Link to comment
Share on other sites

Thank you all for your quick responses.

I am using chief architect premier x7.


I am using the all on set.

I select from build menu, roof truss.

Then I go to the non gable wall, left click to start drawing of truss (it doesn't even change the style of the drag to look like a truss) and then when I release on the opposite non gable wall, it gives the question: "Could not create roof truss at this location because no roof planes were found. Would you like to create a general framing member instead?"


I want to say there is a bug with the version of chief I am using but I know there isn't because I created a new file and was able to create trusses on the building I drew in the new file.


That makes me ask is there a way to copy everything from my existing file (land/ house etc.) to a new file so that I can complete the building portion that I am having problems with.


As I stated previously, I don't really understand what could be causing this at all.


Thank you all for any additional responses you may have.

Link to comment
Share on other sites

Hi,  I Opened your plan in X9 , and as others said Trusses Frame just fine ,  but since you have now posted that you are using X7 still, I opened it in X7 and found exactly as you did that Trusses do not work ..... this is because you built the "outbuilding" on Level 0 (zero)  which is used for Foundations only (usually) .


To fix it while on level 0  goto Build>Floor>insert Floor  and you should now be able to Build/draw trusses.... at least I can here....



PS it's a go idea to goto to the top RH corner and click on your User Names and goto Account Settings>Signature and Add your Name , Version etc to your Signature like most of us have done as different versions required different answers..


  • Upvote 1
Link to comment
Share on other sites

I was a bit surprised myself actually ...I thought it might be a "Home Designer" Plan at 1st , I didn't notice in X9 it was on 0 , as I don't expect to see structures on 0, but at least the fix was simple this time around.....


Not sure why that has changed in X9 ....some "Power User" must of requested it  :)

Link to comment
Share on other sites

Believe it or not, I was "on" to what was going on. I had just started down the thought process of what you all answered and proved to be true.


I had it on the "0" layer by design but didn't really know the caveat that you guys just informed me of.


The backstory of that small file is my dad is wanting a covered open carport where the walkout basement was and we were trying a few different designs (roof styles/ sizes etc.)-- I thought the framing post were causing the issue so I put walls in. I tried 100 different things before I came to the forums for help (of course many of the things I tried made no since but I was trying my best). :-)


Also, I just wanted to say you guys are great. Every time I come to this forum with my small/ somewhat beginner problems, you all are so helpful and never any judgment. Honestly, thank you all so much!


Again, thank you all for helping me out with this one.


*side note, by profession, I am a civil engineer/ PE so a lot of the programs we use take a definite amount of "massaging" to get the results we want and I see that may also be true on the architectural side of things.

Link to comment
Share on other sites

this more like it ?    at least now it isn't floating 9' above your terrain :)   you forgot to set the new floor and ceiling heights to match the Terrain


to fix the roof once I set the floor height , I switched all walls back to hip and rebuilt them all , they turned on the gables again and rebuilt again ...


then changed the walls to a "Railing" , with Post to Beam , with 4" Newels and Rail width on Autosize or turned off like in this pic....






  • Upvote 1
Link to comment
Share on other sites

I noticed after the last post , that the rebuilding of Roofs had caused two roofs to be built, one under the other, over the Porch side of the house , so I have fixed that , and added a Slab to the porch floor too ....not sure if it wasn't there Or I broke it somehow earlier...


And since it's for you Dad I thought we'd upgrade him to Cedar as well on the Outbuilding....





Link to comment
Share on other sites


Yes!! That is much more like it. 

Yeah I saw it floating but was just getting to the point where I was annoyed with it so I threw my hands up and posted another question. (I figured if I could get the carport to look right, surely I could get it to the right elevation with some work)

I think the rebuilding is where I mess up sometimes, I make so many mistakes that I think the program freaks out on me and doesn't know what to do (Because my attic level on plan showed attic walls but the 3D never generated them).

Also, thank you for catching the roof issue on the actual house, I also caught it last night. That is def due to me rebuilding roof planes and forgetting to check the edited checkbox when rebuilding so that chief wouldn't touch those planes.

The no slab may just be from me not knowing what I'm doing :-)

That cedar is awesome.

Mick thank you so much for taking your time to work on this to help me! I am learning slowly but surely!!

Link to comment
Share on other sites

Hi , glad to help..... I find it best to leave Auto Build Roofs on most of the time unless things are really Complex, Chief is really good at simple roofs , if they are set up right in the Defaults and then on the Wall's Roof Tab. AutoBuild will also cause the Gable walls , trim etc to be rebuilt at the same time , which is where I think you maybe running into issues.

Either that or get very used to going upto Roofs and hitting Rebuild all the time. just remember like all general rules you will need to disable Autobuild sometimes and do things manually but manually done Roof planes can be saved in a rebuild too, but when all else fails revert to Auto Build and start again....

  • Upvote 1
Link to comment
Share on other sites

Please sign in to comment

You will be able to leave a comment after signing in

Sign In Now

  • Member Statistics

    Total Members
    Most Online
    Newest Member